[jdom-interest] Can't we all get along? :) -- [is] getChild()
James Duncan Davidson
duncan at x180.com
Wed Aug 2 18:10:42 PDT 2000
on 8/2/00 3:41 PM, Patrick Dowler at Patrick.Dowler at nrc.ca wrote:
> Yesterday I suggested option C - hidden in with my suggestion that the
> singular should be just "get(String name)" - simply because "Child" is
> superfluous anyway: you aren't expecting getting siblings, parents, or
> grand-children with such a call. In addition, you only get elements by name.
Yep... I saw that you did after my post while slogging through the rest of
the email in here. :)
> I'm in favour of "getElements". For the singular, I'd prefer "get" because I
> don't see anything more verbose being any better.
In the same vein you could argue for add* to be shorter as well. Hrm.
> Good analysis of the current state.
More information about the jdom-interest