[jdom-interest] Troubles building JDOM version: jdom-05jun2000-src.tar.gz

Brett McLaughlin brett.mclaughlin at lutris.com
Thu Jul 13 17:47:46 PDT 2000

Ryan O'Connell -HESE wrote:
> Hey folks,
> I am new to JDOM and seem to be having some difficulties.  I pulled down
> the jdom-05jun2000-src.tar.gz and had problems building the source The
> exact error is:
> Java and XML Build System
> -------------------
> Building with classpath
> :/pos/tools/jdk1.2/lib/tools.jar:./lib/xerces.jar:./lib/ant.jar:/pos/tools/jdk1.2/lib/dev.jar
> Starting Ant...
> Buildfile: build.xml
> Project base dir set to: /home/ryano/download/jdom-june-05/jdom
> Executing Target: init
> ----------- Java Document Object Model (JDOM) 1.0beta4 [2000]
> ------------
> Executing Target: prepare
> Executing Target: prepare-src
> Executing Target: compile
> Compiling 1 source files to
> /home/ryano/download/jdom-june-05/jdom/build/classes
> /home/ryano/download/jdom-june-05/jdom/build/src/org/jdom/input/DOMBuilder.java:316:
> Method getPublicId() not found in interface org.w3c.dom.DocumentType.
>                 String publicID = domDocType.getPublicId();
>                                                         ^
> /home/ryano/download/jdom-june-05/jdom/build/src/org/jdom/input/DOMBuilder.java:317:
> Method getSystemId() not found in interface org.w3c.dom.DocumentType.
>                 String systemID = domDocType.getSystemId();
>                                                         ^
> 2 errors
> BUILD FATAL ERROR: Compile failed, messages should have been provided.

I have heard this several times, but cannot repeat the error, no matter
how hard I try... get the latest from CVS, though... see comments below.

> I pulled down jdom-01jun2000-src.tar.gz, and jdom-b4-src.tar.gz but I
> got the exact same error when building.  The interface in question seems
> to live in the xerces.jar file.  Is there an updated version of this jar
> floating around somewhere, what I missing??
> I also tried to get the cvs version and was given the following error:
>     cvs login: Sorry, you don't have sufficient access to
> :pserver:anonymous at cvs.jdom.org:/home/cvspublic
>     cvs [login aborted]:
> :pserver:anonymous at cvs.jdom.org:/home/cvspublic/CVSROOT: No such file or
> directory
> Again, am I missing something??

I just did:

C:\projects\dev>cvs -d :pserver:anonymous at cvs.jdom.org:/home/cvspublic
(Logging in to anonymous at cvs.jdom.org)
CVS password:

C:\projects\dev>cvs -d :pserver:anonymous at cvs.jdom.org:/home/cvspublic
co jdom
cvs server: Updating jdom
U jdom/LICENSE.txt
U jdom/README.txt
U jdom/TODO.txt
U jdom/build.bat
U jdom/build.sh
U jdom/build.xml
cvs server: Updating jdom/contrib
cvs server: Updating jdom/contrib/org

and it worked great...???


> Thanks in advance for any help, sorry if these are silly questions but I
> didn't see any posts in the archives that seemed to answer these
> questions,
> Ryan O'Connell
> _______________________________________________
> To control your jdom-interest membership:
> http://lists.denveronline.net/mailman/options/jdom-interest/youraddr@yourhost.com

Brett McLaughlin, Enhydra Strategist
Lutris Technologies, Inc. 
1200 Pacific Avenue, Suite 300 
Santa Cruz, CA 95060 USA 

More information about the jdom-interest mailing list