[jdom-interest] Important proposal: Element/Document changes
joel.eddy at medinex.com
Wed Jul 26 14:28:45 PDT 2000
could you unsubscribe the netivation address and keep the medinex one.. i
seem to be getting two of each email
From: James Duncan Davidson [mailto:duncan at x180.com]
Sent: Wednesday, July 26, 2000 1:40 PM
To: philip.nelson at omniresources.com; jdom-interest at jdom.org
Subject: Re: [jdom-interest] Important proposal: Element/Document
on 7/25/00 7:15 AM, philip.nelson at omniresources.com at
philip.nelson at omniresources.com wrote:
> I am not overwhelmed by this proposal. Not because the ideas aren't good,
> but because they aren't that much improved over the current api.
The API is showing a bit of maturity. :)
>> Is that true? Naming this method getContent() might be nicer but that
>> will cause subtle bugs to existing code. This also makes it clear the
>> List may contain various types of objects.
> getContent would be better of course. Fine with all whitespace. Since
> old getContent returned a String, wouldn't the compiler catch those?
Actually, given that this is pre-1.0 and you have a chance to fix something
-- and everybody using this code *should* know that things can change willy
nilly -- are we sure that this isn't a good time to cut to the chase and
just name getContent what it is?
I know that the door is closing fast -- but the door will never be open
again and you'll have to live with this for a long time. OTOH The most
compelling argument is that it's documented in the book.. So there's legacy
there that cannot be recaptured.
To control your jdom-interest membership:
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the jdom-interest