[jdom-interest] getChild() vs. getChildElements()

James Todd jwtodd at pacbell.net
Mon Jul 31 12:24:48 PDT 2000

Jason Hunter wrote:


> With
> getChildElement() the method I would use most would have to be named
> getChildElementTextTrim() and about the 10th time I call that method in
> a row (since you call these accessor methods a lot) I'm going to get as
> fed up with JDOM as I was with DOM.  Well, maybe not *that* annoyed, but
> close.  :-)

oh my ... i see your concern.

<appologies for not diving into the api in detail yet again/>

is is possible to push the "textTrim" and the likes to a helper/util
class vs mondo long and overloaded method names and
perhaps functionality?

- james

More information about the jdom-interest mailing list