[jdom-interest] First impressions and some suggestions

bob bob at werken.com
Fri Jun 2 10:50:05 PDT 2000

> other names are welcome.  getContentRaw() is the best I've come up with
> but don't really like it.  getRawContent()?  getUntrimmedContent()? 
> Hmm...

	Not to throw yet-another 'me too' on the stack, but
	I'd personally prefer getContent() to return the content,
	as defined by the XML spec.  That just seems to be
	what 'get content' means to me.  No adjectives, no
	molestation of the content.

	Iff it's decreed that getContent() returns the trimmed
	content, then instead of getRawContent() to return the
	full content, including surrounding whitespace, I kinda
	like the name getFullContent().  There's nothing particularly
	'raw' about the content with spaces around it.  'Raw', to
	me, means that things like entities aren't expanded,
	etc.  (just a bundle of bytes, not unlike the CDATA
	we're going around about).

		(sorry, I'm a sucker for semantics)

More information about the jdom-interest mailing list