[jdom-interest] XMLOutputter naming questions

Louis Tribble louis.tribble at metamata.com
Mon Oct 2 12:35:46 PDT 2000

Alex Chaffee wrote:
> +1 on outputString, since "get" generally refers to a *property* of
> the object, and String is not a property.  "outputString" is more
> descriptive of what it's really doing.


outputString() implies to me that output (some state change to the
external environment) is happening, but it isn't. 

There is some precedent for calling such methods "to<class>()". If, in 
this case, toString() is not comfortable (because of its presumptive
debugging usage), we could fall back to toXMLString(), or some such.
For myself, toString() seems fine.


Louis Tribble                                         louis at metamata.com
Metamata, Inc.                                   http://www.metamata.com
Tools for serious Java developers.                       +1 510 796 0915

More information about the jdom-interest mailing list