jhunter at acm.org
Wed Aug 1 12:01:10 PDT 2001
bob mcwhirter wrote:
> Working on the JDOM DocumentNavigator for Jaxen, and am noticing
> inconsistencies in the API:
> To obtain the text of a Text node, we use getValue(), where to obtain
> the text of CDATA node, we have getText().
Note that currently Text is not used, it's just a "whiteboard" class.
So there's no inconsistency yet. Should perhaps getValue() be replaced
with getText(), thus pushing existing naming conventions onto the new
class? I'm easy.
More information about the jdom-interest