[jdom-interest] Re: JDOM via Servlet

John Muhlestein jmuhlestein at i-link.net
Wed Jul 25 10:39:07 PDT 2001

I am using the same setup except on Linux (apache AJP12 and tomcat 3.2.1)  
I am starting to suspect some kind of configuration problem with tomcat.  I
had seen a brief mention somewhere (I believe from Jason, though not on this
listing) about possible conflicts with tomcat's default parser and confusion
with the parser (in my case xerces 1.4) that I put in my application's
context.  I have put a copy of the xerces jar file in the global lib
directory for tomcat (renamed 00_xerces.jar) so that it will load before
parser.jar.  This still did not seem to do the trick.  Is there anything
else you can think of?

Thanks for all the help


BTW, if you created an output file then yes, the build process worked
(thank God I'm not completely insane)

> -----Original Message-----
> From: Ian Lea [mailto:ian.lea at blackwell.co.uk]
> Sent: Wednesday, July 25, 2001 11:22 AM
> To: John Muhlestein
> Cc: 'jdom-interest at jdom.org'
> Subject: Re: [jdom-interest] Re: JDOM via Servlet
> Had to remove references to WhlslXMLProcessor from the
> servlet source file to get it to compile but after that
> it worked first time.  At least I assumed it worked:
>  Installed the servlet
>  Ran "java ...WhlslPostTest infile outfile" and it created
>    an xml output file.
> Done on solaris using apache with AJP12 and tomcat 3.2.1.
> What servlet engine are you using?
> --
> Ian.
> John Muhlestein wrote:
> > 
> > Still no-go...
> > Here are the copies of the code for those who asked.
> > 
> > thanks,
> > John

More information about the jdom-interest mailing list