[jdom-interest] getMixedContent -> getContent

Elliotte Rusty Harold elharo at metalab.unc.edu
Thu Jun 28 07:50:47 PDT 2001

I wanted to weigh in on this. I just looked through the JavaDocs, and 
it seems very clear to me that getChild should be renamed 
getChildElement(), getChildren() should be renamed 
getChildElements(), and so forth through the API. The current API is 
way too confusing on this point.

Longer term, I wonder if there's some way we can add an overloaded 
getContent() method that takes some sort of filter object as an 
argument, so that users could pass in filters to get only comments, 
only text nodes, only text nodes that weren't ignorable white space, 
only elements in a certain namespace, etc.

| Elliotte Rusty Harold | elharo at metalab.unc.edu | Writer/Programmer |
|          The XML Bible, 2nd Edition (Hungry Minds, 2001)           |
|              http://www.ibiblio.org/xml/books/bible2/              |
|   http://www.amazon.com/exec/obidos/ISBN=0764547607/cafeaulaitA/   |
|  Read Cafe au Lait for Java News:  http://www.cafeaulait.org/      |
|  Read Cafe con Leche for XML News: http://www.ibiblio.org/xml/     |

More information about the jdom-interest mailing list