[jdom-interest] Last call: getChild/getChildren versus getChi ldElement/getChildElements

Rolf Lear rlear at algorithmics.com
Fri Feb 6 09:23:54 PST 2004

For the record, I am for making getChildElement....()

Also, I agree with renaming child to content, but Parent should then be
renamed to Container.


-----Original Message-----
From: jdom-interest-admin at jdom.org
[mailto:jdom-interest-admin at jdom.org]On Behalf Of Jason Hunter
Sent: Thursday, February 05, 2004 6:12 PM
To: jdom-interest at jdom.org
Subject: [jdom-interest] Last call: getChild/getChildren versus


Do we need to change Parent's name then?  I'm thinking not since 
getParent() should return a Parent.  Yes, we'll have a Parent/Content 
pairing which doesn't roll off the tongue, but hey, at least everyone 
won't have to change all their getChild() and getChildren() calls, we'll 
have getContent() return Content, and I won't get yelled at.

So here's my proposal:
* Change Child to Content
* Remove getChildElement and getChildElements
* Undeprecate getChild and getChildren


To control your jdom-interest membership:

More information about the jdom-interest mailing list