[jdom-interest] Last call: getChild/getChildren versus getChi ldElement/getChildElements

Phill_Perryman at Mitel.COM Phill_Perryman at Mitel.COM
Fri Feb 6 11:48:41 PST 2004

Oh good, can getParent also be renamed to getContainer() so it is lexically
consistent and also so I can extend Element and Implement MutableTreeNode
at the same time (Swing programming would be so much easier)..

IS Dept, Software Engineer.
phill_perryman at mitel.com
Tel: +44 1291 436023

                      Rolf Lear                                                                                                        
                      <rlear at algorithmic       To:       "'Jason Hunter'" <jhunter at servlets.com>, jdom-interest at jdom.org               
                      s.com>                   cc:                                                                                     
                      Sent by:                 Subject:  RE: [jdom-interest] Last call: getChild/getChildren versus getChi             
                      jdom-interest-admi         ldElement/getChildElements                                                            
                      n at jdom.org                                                                                                       
                      06/02/2004 17:23                                                                                                 

For the record, I am for making getChildElement....()

Also, I agree with renaming child to content, but Parent should then be
renamed to Container.


-----Original Message-----
From: jdom-interest-admin at jdom.org
[mailto:jdom-interest-admin at jdom.org]On Behalf Of Jason Hunter
Sent: Thursday, February 05, 2004 6:12 PM
To: jdom-interest at jdom.org
Subject: [jdom-interest] Last call: getChild/getChildren versus


Do we need to change Parent's name then?  I'm thinking not since
getParent() should return a Parent.  Yes, we'll have a Parent/Content
pairing which doesn't roll off the tongue, but hey, at least everyone
won't have to change all their getChild() and getChildren() calls, we'll
have getContent() return Content, and I won't get yelled at.

So here's my proposal:
* Change Child to Content
* Remove getChildElement and getChildElements
* Undeprecate getChild and getChildren


To control your jdom-interest membership:

To control your jdom-interest membership:

More information about the jdom-interest mailing list