[jdom-interest] Imcompatibility with GPL

Edelson, Justin Justin.Edelson at mtvn.com
Thu Sep 28 07:39:05 PDT 2006

> Its a shame that I have to change to another XML parser. =(
JDOM isn't an XML parser. See http://jdom.org/docs/faq.html#a0010
While I doubt there's much interest (or need) in changing the license,
out of curiosity, what are the "minor issues" that the FSF finds


From: jdom-interest-bounces at jdom.org
[mailto:jdom-interest-bounces at jdom.org] On Behalf Of Henttonen Katja
Sent: Thursday, September 28, 2006 8:11 AM
To: jdom-interest at jdom.org
Subject: [jdom-interest] Imcompatibility with GPL

I tried to register a new free software project at Savannah and learned
hat JDOM is not
compatible with GPL and thus cannot be legally combined with GPL'ed
I have previously heard several people claiming that, as JDOM uses a
BSD-style license, it should be GPL-compatible.  But I just found out
this is not the case.

Has anyone considered removing or changing the minor issues that make
JDOM incompatible
with GPL? Its a shame that I have to change to another XML parser. =(
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.jdom.org/pipermail/jdom-interest/attachments/20060928/02d4d3df/attachment.htm

More information about the jdom-interest mailing list