[jdom-interest] Java 1.5 language features.

Michael Kay mike at saxonica.com
Mon Feb 26 14:27:56 PST 2007

> What happens when Software A uses JDOM 2.0 while Software B 
> uses JDOM 1.0, and you want to write Software C that uses 
> both Software A and Software B?  Can you just drop in JDOM 
> 2.0, ignore JDOM 1.0, and have Software B (built maybe 
> against an old version of Java) satisfied? 
> Anyone have experience with this?

Well if you generalize "JDOM" to "X" and 1.0/2.0 to M/N, then we all have
experience of it, and it's not usually a pleasant memory.

Michael Kay

More information about the jdom-interest mailing list