[jdom-interest] About Jdom licence

Paul Libbrecht paul at activemath.org
Fri Mar 2 13:36:04 PST 2007

Pelisse Romain wrote:
> Hi everyone,
> I have very simple question about the jdom's licence. I wish to use 
> jdom in a GPL project, and as some of you may know, only Apache 
> Licence V2 is compatible with GPL. I couldn't find (even in the 
> source), the Apache Licence version number on which is based the jdom 
> licence... Would you be kind enought to help me with this ?

JDOM license is not the Apache license, neither 1.0 nor 2.0. JDOM 
license is very close to the Apache 1.0 but differs a little bit. 
Unfortunately, you have to download the software to read the license... 
not really cool but... this reflects the wish to be problem-free of such 
a liberal license.

Now, you say it's incompatible with GPL, well... those are legal matters 
that have made everyone tired and seems to be a claim, solely, of FSF, 
which has never prevented many GPL distributions to ship, for example, 
with the Apache server, even when it was under the Apache license 1.0.
Also, the claim that version 2.0 would be compatible with the GPL was 
unfortunately, held only for a week after its release. After this week, 
yet another guy of the FSF indicated another incompatibility.

I'm afraid you'll have to live with an imperfect incompatibility.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 2938 bytes
Desc: S/MIME Cryptographic Signature
Url : http://www.jdom.org/pipermail/jdom-interest/attachments/20070302/669fe33e/smime.bin

More information about the jdom-interest mailing list