[jdom-interest] Opinion Poll: - JDOM2 and minimum-required Java - Java5 or Java6

Rolf jdom at tuis.net
Wed Dec 7 17:25:47 PST 2011

Hi all.

I have 'finalized' the 'support' of Java5 in JDOM2.

Unless someone can come up with a *very* compelling reason:

- JDOM2 will support only Java6 and newer.
- JDOM2 core functionality will run on Java5 with some limitations, 
documented issues, and workarounds.
- issues in JDOM2 will be addressed if they are reproduced in Java6 or later
- issues that affect Java5 only will also be considered, but with closer 
scrutiny. A fix will not be considered if it impacts functionality in 
later Java versions.

The list of issues and workarounds with JDOM2 on Java5 will be 
maintained: https://github.com/hunterhacker/jdom/wiki/JDOM2:-Using-Java5

See the 


More information about the jdom-interest mailing list