[jdom-interest] Opinion Poll: - JDOM2 and minimum-required Java - Java5 or Java6

Rolf Lear jdom at tuis.net
Mon Oct 31 06:26:19 PDT 2011

I should add a time-line here.

I think I will sit on this for a couple of weeks... Say Friday the 18th - 
three weeks.

At that point I will summarize all the responses... and between now and
then I will also see if I can come up with a more detailed list of what the
implications for supporting Java5 are...

Then we can make a more informed decision.

A third option would be to only officially support Java6, but also put
together a document on how to make it work with Java5.


On Sun, 30 Oct 2011 21:56:44 -0400, Rolf <jdom at tuis.net> wrote:
> Hi all.
> ...
> So, as a poll:
> * Does anyone have a realistic need to run a future JDOM2 on Java5?
> * If so, could you add additional jars to your classpath just to make 
> JDOM2 work?
> * Any comments, suggestions.
> Currently I feel that it is reasonable to set Java6 as a minumum and not

> even bother trying to think about Java5 issues... anyone disagree?
> Rolf
> _______________________________________________
> To control your jdom-interest membership:
> http://www.jdom.org/mailman/options/jdom-interest/youraddr@yourhost.com

More information about the jdom-interest mailing list