[jdom-interest] Stirring up Trouble

tsasala at hifusion.com tsasala at hifusion.com
Thu Jul 20 05:08:04 PDT 2000

	I think getTextContent would be more intuitive.  However, a method
such as that begs the question of where getIntContent, etc. is.....
I don't think any getContent like method should be recursive
across the board.  That behavior is not intuitive (to me).

Alex Chaffee wrote:
> I haven't read the rest of this thread yet (hmm, sounds like "I don't
> really know Java but...") but I thought I'd get this out since I don't
> know when I'll log on next:
> I think "getContent()" is ambiguous, so we should replace it with
> something like "getText()" which means exactly what we want it to
> mean.  For me, that would be stripping whitesapce, and calling
> getText() recursively on non-string children, but I'm willing to
> negotiate.
> I will now download and read the rest of the thread.
>  - Alex (on a slow slow pipe in Singapore)
> _______________________________________________
> To control your jdom-interest membership:
> http://lists.denveronline.net/mailman/options/jdom-interest/youraddr@yourhost.com

More information about the jdom-interest mailing list