[jdom-interest] XMLOutputter naming questions

Alex Chaffee guru at edamame.stinky.com
Sun Oct 1 13:39:56 PDT 2000

On Sun, Oct 01, 2000 at 12:34:17PM -0700, Jason Hunter wrote:
> > Just read TODO.txt: "Write
> > XMLOutputter.serialize(doc/elem/comment/doctype/entity/pi/attrib). 
> > Have
> > these methods replace getSerializedForm().  Going this way allows
> > tweaks to the XMLOutputter behavior before serialization."
> >
> > I think "serialize" is the wrong word; "output" is better for this,
> > since it's consistent with the name of the object, isn't confused with
> > other meanings of "serialize," etc.
> Elliotte, are you still around?  I believe you chose the name
> getSerializedForm() initially.  Do you want to justify the use of
> "serialize"?

While we're at it, I'd like to change




(a) it's better to be consistent (omit vs. suppress are synonyms)

(b) it's better for a boolean to represent a positive concept, not a
negative concept -- double-negatives are hard

I'd also like the default for encoding to be *not* to show it, but
that may just be my prejudice, since I deal mostly with simple XML
files.  Anyone have a real need for the encoding to be shown by
 - A

Alex Chaffee                       mailto:alex at jguru.com
jGuru - Java News and FAQs         http://www.jguru.com/alex/
Creator of Gamelan                 http://www.gamelan.com/
Founder of Purple Technology       http://www.purpletech.com/
Curator of Stinky Art Collective   http://www.stinky.com/

More information about the jdom-interest mailing list