[jdom-interest] getChildren() vs getElements()
Andre Van Delft
avandelft at epo.org
Mon Sep 18 01:22:28 PDT 2000
"Peter V. Gadjokov" wrote:
> But point taken, I'll try to make my spewage more brief and structured. What
> I was suggesting was -
> - Move away from the 'tree-of-everything' model
> - Adopt a 'tree-of-elements' model
> - change the API to reflect this
> - children/parent stay and make sense and are about Elements
> - content (as a collection of everything
> in an element) becomes superfluous and is removed
> - change the implementation to reflect this
> - less PartialList, more type-specific containers
But should addChild then stay? I quote from my posting of July 21:
> I find the name getChildren misleading.
> When I do an addChild(String), I would expect this to
> influence the result of a call to getChildren(). It does not.
> I propose to replace the name by getChildElements().
> Alternatively addChild(String) could be renamed addString(String).
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the jdom-interest