[jdom-interest] <kein Betreff>

Michael Kay mike at saxonica.com
Thu Oct 13 09:55:49 PDT 2005

> I've been waiting to see best practices from other projects.  

The more widely used the package, the more conservative you have to be.

On Saxon I've more-or-less stopped getting any hassle over the fact that it
requires JDK 1.4, but it's taken a long time to get to that point. I reckon
in about a year or 18 months it might be acceptable to do a JDK 1.5-only

This is a particular problem for Saxon because of the incompatibilities
between JDK 1.4 and JDK 1.5 in the DOM area. The sooner I can move forward
the better, but at the moment, you'd be cutting off far too many users. It's
a hassle, and there's no easy answer.

Michael Kay

More information about the jdom-interest mailing list