[jdom-interest] JDOM 1.1.1 release candidate

Elliotte Rusty Harold elharo at ibiblio.org
Thu Jul 23 07:20:13 PDT 2009

On Thu, Jul 23, 2009 at 7:04 AM, Brad Cox<bcox at virtualschool.edu> wrote:

>> Jason, FYI the reason I stopped using JDOM after years of satisfied use
>> was inability to make it coexist with OSGI. As I recall, the problem was
>> trivial; 2-3 classes in the default namespace which gives OSGI fits. Been
>> awhile since I've looked tho.


OSGI is a colossal time sink that only looks simple; but really,
really isn't. I have learned this the hard way. It is poorly
documented, and virtually untestable. It is like Maven on PCP.

Please don't succumb to the temptation to make a few more changes just
to support OSGI. If you want to support OSGI (which I'm finding to be
a lot more trouble than it's worth over in XOM) then please do it in
1.1.2 rather than holding 1.1.1 for it. There are critical bug fixes
in 1.1.1 that are useful without OSGI support.

Elliotte Rusty Harold
elharo at ibiblio.org

More information about the jdom-interest mailing list